System Alert: FEP® Insights - Production (O2) - Telephone Consumer Protection Act - Reports Unavailable

Incident Report for FEPOC Status Page

Resolved

Current Status

The FEPOC resolved the slowness and errors in FEP® Insights Telephone Consumer Protection Act (TCPA) reports.

For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
Posted Apr 13, 2026 - 10:11 EDT

Identified

Plan Impact
Plans and partners are experiencing report unavailability.

What Is Happening?
The FEPOC is investigating an issue with FEP® Insights Telephone Consumer Protection Act (TCPA) reports being unavailable.

Who Is Affected?
All Plans

How This Impacts You
The DNC reports are downloaded slowly. The user needs to wait for some time to download the report from FEP Insights.

Current Status
We will provide you with an update on the situation when the issue is resolved.

For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
Posted Apr 12, 2026 - 12:47 EDT
This incident affected: Data Products (Prod) (Telephone Consumer Protection Act (TCPA) (Prod)).