System Alert: FEPDirect Claims and Retrieval Applications – Production – Slowness

Incident Report for FEPOC Status Page

Resolved

Current Status
The slowness issue has been resolved. We will continue to monitor performance.

Root Cause is still under investigation. Coordinating with BCBSA BluesNet to complete the detailed RCA.

How This Impacts You

The FEPDirect Claims and Retrieval applications are now available for all Plans.
Posted Apr 17, 2026 - 14:35 EDT

Identified

What Is Happening?
The FEPOC is investigating reported errors in the FEPDirect Claims and Retrieval applications in the Production (O2) environment.

Who Is Affected?
All Plans

How This Impacts You
Plan users are experiencing slowness and receiving error messages in the FEPDirect Claims and Retrieval applications.

Current Status
We are addressing this issue, and an update will be provided when it is resolved.

For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
Posted Apr 17, 2026 - 10:31 EDT
This incident affected: Claims (Prod) (FEPDirect Claims (Prod), FEPDirect Retrieval (Prod)).