What Is Happening? The FEPOC resolved the slowness and timeouts that were occurring in the FEPDirect Claims and Workflow applications in the Production (O2) environment.
Who Is Affected? All Plans
Current Status This issue is resolved. We will continue to monitor performance. For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
Posted Oct 17, 2025 - 09:15 EDT
Identified
Plan Impact Plans and partners are experiencing slow system performance.
What Is Happening? The FEPOC is investigating reported slowness in the FEPDirect Claims and Workflow applications in the Production (O2) environment.
Who Is Affected? All Plans
How This Impacts You Plan users are experiencing slowness, timeouts and receiving blank pages in FEPDirect Claims and Workflow application.
Current Status We are addressing this issue, and an update will be provided when it is resolved.
For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
Posted Oct 17, 2025 - 08:33 EDT
This incident affected: Claims (Prod) (FEPDirect Claims (Prod)) and Enrollment (Prod) (Intake & Workflow (Prod)).