System Alert: FEP® Insights – Production – Availability

Incident Report for FEPOC Status Page

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:04 EDT

Identified

Plan Impact
Plans and partners are experiencing report unavailability.

What Is Happening?
The FEPOC is investigating an availability issue with FEP® Insights reports in the Production (O2) environment.

Who Is Affected?
All Plans

How This Impacts You
An AWS outage occurred this morning that impacted system availability.

Current Status
Our teams are actively monitoring the situation and will provide updates as more information becomes available and when the issue is resolved. We appreciate your patience and understanding.

For questions or assistance, please visit the Technical Support page on FEPOC BlueWeb.
Posted Oct 20, 2025 - 14:53 EDT
This incident affected: Data Products (Prod) (Claims Processing (Prod), DataBasics (Prod), Customer Service (Prod), Field Services (Prod), Telephone Consumer Protection Act (TCPA) (Prod)).