The Release 3 2025 changes have been implemented successfully, and all online systems will resume the normal schedule.
Who is Affected? All Plans.
How This Impacts You Release 3 2025 implementation activities for 2025BLP028 – Care Coordination Technical Infrastructure (CCTI) Support and are not yet complete. The FEP Cognos and Advantage Suite Production applications will remain unavailable to facilitate the implementation and system maintenance activities. Additional Plan Notifications will be sent upon completion of these activities.
Posted Oct 11, 2025 - 20:24 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 10, 2025 - 16:50 EDT
Scheduled
What Is Happening? The Release 3 2025 Production (O2) Environment Implementation will occur between Friday, October 10, 2025, at 2:00 p.m. Eastern Time (ET) through Saturday, October 11, 2025, at 11:59 p.m. ET.
The Release 3 2025 implementation includes maintenance of the Enterprise Data Platform (EDP), which will begin on Friday, October 10, 2025, at 2:00 p.m. ET.
Additionally, on Saturday, October 11, 2025, starting at 1:30 a.m. ET, all applications will be unavailable until the conclusion of the Release 3 2025 implementation into Production (O2).
Who Is Affected? All Plans
How This Impacts You Cloudera and Ab Initio are key components of the EDP maintenance, and FEPOC has a need to perform an upgrade for both these components.